Free 14-Day Evaluations    
Product Downloads    

Sign in     


PRODUCTS DOWNLOAD PURCHASE SUPPORT PARTNERS COMPANY
 Home  >>  Documentation  >>  TinyTERM for Mac  >>  Using TinyTERM for Mac



“You have the best technical support I've ever received from any software company. Knowing I will get support like yours made it real easy to pay for the upgrade.”
— Bruce Frank

Using TinyTERM for Mac

In addition to rock-solid telnet, SSH and SSL/TLS connectivity, TinyTERM for Mac has several features to increase usability. Quick access to connecting and disconnecting, coupled with the ability to open multiple tabs and windows, and to import and export settings for use with other desktop TinyTERM products, gives users flexibility and enhanced productivity.

Multiple Tabs and Windows

To open a new tab in the current window, select New Emulator Tab from the File menu, or type ⌘T. The new tab opens with the current configuration settings.

To open a new window, select New Emulator Window or type type ⌘N. A new window opens, again with the current configuration. In either case, typing type ⌘, to bring up the Preferences dialog allows you to select or create a different configuration if desired.

Function Key Button Bar

The function key button bar has been updated to be fully customizable. Function keys on the default layouts can be clicked in place of using those the physical keyboard, and will act as the function keys from the selected terminal emulation.

The button bar can also be turned on or off on from the Edit menu, or at a single keystroke To bring it up or hide it from the main keyboard, type ⌘K.

Keyboard Shortcuts

In addition to the keyboard shortcuts described above, most menu items can be accessed with one. For example, you can print the screen by selecting Print Screen from the File menu, or by typing ⌘P. Copy and paste use the Mac-standare ⌘C and ⌘V shortcuts. And each window is assigned its own numeric shortcut in the order opened. So the first window can be reached with ⌘1, the second with ⌘2, etc.

Telnet Keepalive

TinyTERM for Mac has one feature that cannot be accessed through the Preferences, telnet keepalive. This feature is available only through changing a setting in the appropriate connection configuration file.

Connection files are stored in the Mac's Application Library. They have a .tpx extension. To locate the files, open a Finder windows. From the Go menu, select Go to Folder... Enter this folder name:

~/Library/Application Support/TinyTERM-ITX

This will open TinyTERM's Application Support folder and display a list of files, including the .tpx files. The files have randomly generated names.

To activate telnet keepalive for a configuration, open the connection file in TextEdit or another text editor application. Move to the end of the file. After the last entry, add this line:

telnetkeepalive=300

The number after the = sign is the number of seconds TinyTERM will sit idle. In the example above that's 300 seconds or five minutes. Adjust this number to your needs, or set it to 0 to disable the telnet keepalive.

After that much time with no activity, TinyTERM will send a telnet NOP packet to the host. This will only work for telnet connections, not local or SSH connections.

  Copyright © 2017 Century Software, Inc. All Rights Reserved (1.0.1)999 TERMS OF USE PRIVACY POLICY EULA